Tutorial for JMatchMap by Agnés Simonet January 2020

JMatch Map

JMM v 2.0
(for Hot Potatoes v7)

The examples in this tutorial are for version 2.0.1.

You can easily adapt them for other versions (2.0.2 etc.)
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| What is a Jmatch Map exercise?

It's a JMatch exercise using drag&drop format where you can drag and drop items onto areas
defined in an image (this kind of image with areas is called image map).

Placer les |légendes sur la carte.

Veérifier |

Oceanie
Europe
Ameérique |

Afrique

Il How to install JMM?

Unzip JMM_201.zip and copy the JMM_201 folder where you want, for example in the source
folder of Hot Potatoes:

'g HotPotatoes7?

r g scorm_schemas

"g source
(] MH_201
& JMM_201
(] “Ms_201
» (] Msv_201

Note: you can copy the folder anywhere on your hard disk and rename it as you like.

Check that the demos, hif and source folders are present:

-& JMM_201

’ ﬁ demos_JMM

» (gl hif MM

» (] source_JMM



Il How to load the interface file

You don't necessarily have to do it but if you load the interface file associated with JmatchMap it will
be easier for you to create your exercise and change the configuration output.

Open JMatch. Click on Options->Interface->Load interface file.

Help

r:% Configure Output | ﬁﬁ E]:P;r @ i

qu.a nght to-Left

. Toolbar Options
Show tooltips | |

F 2 J I]rag

Eg Reload Config Info from File §—

%- Iranslate the Interface

ey Resat Default Interface
E Clear source file location 'I@) —

'E'g Set source fite location

Browse to the folder JMM_201/hif_JMM and choose the JMM_201_en.hif (or JMM_201_fr.hif) file.

Load a Hot Potatoes Interface file

Rechercher | hif_] MM ﬂ

[ | JMM_201_en hif
[~ ] JMM_201_fr hif

It would be great if we had interface files in other languages... There is only some sentences to
translate. If anybody wants to write one, please contact me on the hotpotatoesusers Yahoo group.

A dialogue box will ask you if you would like to change the interface for all applications. Choose “No*.

Confirm m

o Would you like to use this interface file for all the applications in this suite?

You will immediately notice the change:

Title JMatchMap for HP7

1:image map code /2,3 etc. : areas code Draggable (jumbled) items Fix

Other changes can be seen in Options>Configuration output.




Il How to create a JMM exercise?

The example refers to the exercise continents.jmt in the demos_JMM folder.

1- You need an image (continents.png which must be in your exercise folder) that you will map. It's
very easy to do and there are lots of softwares that can do it, even online. | recommend Gimp as it
is a cross-platform software and very easy to use.

If you
few m

do it for the first time you will perhaps make it in half an hour but after that it will take only
inutes.

See the detailled procedure in image_map_tutorial.pdf

At the
map:

<img

<area
<area
<area
<area
<area
</map

end you will have a text file (continents.png.map) whose content is the code for the image

src="continents.png" width="536" height="258" border="0" usemap="#map" />

name="map">

#$-:Image map file created by GIMP Image Map plug-in -->

#$-:GIMP Image Map plug-in by Maurits Rijk -->

#S-:Please do not edit lines starting with "#$" -->

#SVERSION:2.3 ——>

#SAUTHOR:AS ——>
shape="rect" coords="463,191,475,203" alt="Océanie" nohref="nohref" />
shape="rect" coords="276,141,288,153" alt="Afrique" nohref="nohref" />
shape="rect" coords="268,53,280,65" alt="Europe" nohref="nohref" />
shape="rect" coords="60,66,72,78" alt="Amerique" nohref="nohref" />
shape="rect" coords="390,53,402,65" alt="Asie" nohref="nohref" />

>

2- Open JMatch.

3- Copy all the text of continents.png.map and paste it in the first left box.

1:image map code / 2,3 etc. : areas code ||

1 <l--

<l--
<l
<l
<l

<img src="continents.png" width="536" height="258" borde="0" usemap="#map" /> -

<map name="map">

#§-Image map file created by GIMP Image Map plug-in —->
#5--GIMP Image Map plug-in by Maurits Rijk --=
#5-Please do not edit lines starting with "#3" =
#VERSION:2.3 >

#PAUTHORAS > =l

Don't write anything in the corresponding right box.

Note :

you can also use the cleaned code (see image_map_tutorial.pdf)


https://www.gimp.org/downloads/

4- In the others left boxes (2,3 etc.) copy and paste the code for each area.

| 1:image map code /2,3 etc. : areas code ||

<l- #VERSION:2.3 > ]
<l- #AUTHOR:AS -->
<area shape="rect" coords="463,191 475 203" alt="Océanie" nohre="nohref" />
1 <area shape="rect" coords="276,141 288 153" alt="Afrique" nohre="nohref" />
<area shape="rect" coords="268 53 280 B5" alt="Europe" nohre="nohref" /=
<area shape="rect" coords="6066 72 78" alt="Amerique” nohre="nohref" />
<area shape="rect" coords="390 53 402 65" alt="Asie" nohre="nohref" />
</map> -
<area shape="rect" coords="276,141|288 153" alt="Afrique" nohret="nohref" /> =] Afrique
2
E
<area shape="rect" coords="463,191 475 203" alt="Océanie" nohre="nohref" /> ;I Océanie
3
=
<area shape="rect" coords="268 53 280 65" alt="Europe" nohref="nohref" /> ;l Europe

In the corresponding right boxes type the text of the draggable cards.
Note 1: you don't have to use all the areas defined in the first left box.

Note 2: you don't have to use the same word(s) in the right boxes that the one(s) in the alt tag for
areas.

5- Now it's time to tell JMatch that instead of using the original source files, the special source files
have to be used.

Press the Shift + Control + ALT + S keys simultaneously.

Choose the special source folder where the necessary file(s) are located

=[5 source i
- [EF1a_50 =
i [CyFb_ 501

[)cdd_s0
[ iMem_s01 J
& MH_201
=5 mm_z201
i E‘Jdemns_] MM
[ nit_jMm

e _@ JMs_201

You will see which source folder is in use :

5 <area shape="circle" coords="357 102 14" alt="5tras

ISuurce: ChProgram Files (x86)\HotPotatoes Msourcey ) MM_201source_| MM‘l.l




6- Create your web-exercice using CTRL + F6 or the appropriate file menu item n2

Be aware that the next time the JMatch program is loaded, it will use this special source files folder.

If you want to create another exercise with the original Jmatch, press the Shift + Control + ALT + T
keys simultaneously.

If you want to create another type of JMatch exercise (using another add-on), press the Shift +
Control + ALT + S keys simultaneously and choose the adequate source folder.

IV Configuration

1- How to modify the opacity?

For some exercises (as continents.htm) you don't want the cards to hide the image. For others
(such as JMM_203_demo2.htm) opaque cards are not a problem.

You can define a value for the opacity of the background of the draggable cards and
droppable areas.

'C.'Ll:anﬁguratic'n file: C:\Program Files (x86)\HotPotatoesTyenglish7.cfg
Undo Insert
Titles/Instructions | Prompts/Feedback | Buttons | Appearance | Timer Other |Custum CGl

User-defined strings

[[Clptiunal] Droppable areas opacity * draggable cards opacity (e.g. : 0.4"0.7) ]

05707

[Optional] Font size (in px,em or %) for text in droppable areas * font size for text in draggable can
160%*20px

[Optional] Auto-highlight of right and wrong items (0: no - 1: yes)
1

The first value (0.5) is for the opacity of the areas (I:j‘_‘)

The second value (0.7) is for the opacity of the draggable cards.
Both values must be between 0 and 1:
o a value of 1 means that the background will be totally opaque.
o a value of 0 means that the background will be totally transparent
The values must be separated by an asterisk (*)
If you keep the box empty the default opacity values will be 1 (totally opaque).

If you use values higher than 1 the opacity values will be set to 1 (totally opaque).



2- How to modify the font sizes?

You can use a font size for the text in droppable areas and the font size for the text in
draggable cards.

Undo Insert

|Titlesrlnstructiuns || F’rnmptsfFeedback” Buttons || Appearance || Timer || Other | Custom | GGl

User-defined strings
[Optional] droppahle areas opacity * draggahble cards opacity (e.g. : 0.4"0.7)
0.470.4

[Optional] font size (in px,em or %) for text in droppable areas * font size for text in draggable card
160%™ 20px

[Optional] Auto-highlight of right and wrong items (0: no - 1: yes - 2: no +wrong items back home)

The first value (160%) is for the font size of the text in the areas ("?")
The second value (20px) is for the font size of the text in the draggable cards.
The values must be separated by an asterisk (*)

You need to specify the unit (px, em or %). For example, if you want a value in px, type
"100px", don’t type "460".

The font size for the text ("?") in the droppable areas determines the height and width of

the droppable area.
‘ 100%3 (

frique Afrique

QOcéanie Oceéanie

urope urope

merique mérique

sie sie

S
ST

If you keep the box empty the default font size will be the one defined in hp7.cs_



3- How to choose the colors for wrongly and rightly positioned items?

You can choose the border color for wrong and right items in Options>Configuration
output>Appearance:

Mavigation bar colour; I#:IDBDDD El

Title

Page background colour: I#fffﬁ? El

Text text text text text text text text text text
text text text text text text text text text Title colour |#:][][][][][] El
Exercice background colour: I#I’SEE El
Link  Visited i Link / border if right}|#0fb55a El
Visited link / border it wrong ; |[#R0000 El

[& Preview | Text colour; |#I]DDDDD El




4- How to enable Practice mode and Test mode?

Undo Insert

|Tit|es!lnstructiun5 || F’rumpts!Feedback” Buttons || Appearance || Timer || Other | Custom | coGl

—User-defined strings
[Optional] droppable areas opacity * draggable cards opacity (e.g. : 0.4*0.7)
0.4%0.4

[Optional] font size (in px,em or %) for text in droppable areas * font size for text in draggable card
160%*20px

[Optional] Auto-highlight of right and wrong items (0: no - 1: yes - 2: no +wrong items back hnm;a]

- Type "1" to enable the Practice mode: in Practice mode the items are automatically
highlighted as soon as they are positioned, using the defined colors (see above, page 8)

Vérifier |
S
= P
s

-

&
LF

Océanie

- If empty or if you type "0" the default mode is Test mode. Answers will be highlighted after
validation.

Votre score 60%.
Désolée... Corrigez.




5- How to define the width of the reading text container?

If you use a reading text (it's now available with JMatch drag and drop, thanks to Martin) you can
easily choose the width of the reading text container.

Options>Configuration output>Custom:

Code for insertion into <head= tag

=style> [ |

div.ReadingContainerdflex-grow: 20;}
div.ExerciseContainerflex-grow: 80;}
</style>

The logic is :
width of {ReadingContainer + ExerciseContainer} : 20 + 80 =100
width of ReadingContainer : 20/100 (20%)
width of ReadingContainer : 80/100 (80%)

So if you want the width of the reading text container to be 40% of the width of the page, use 40
for ReadingContainer and 60 (=100-40) for ExerciseContainer. So type:

<style>
div.ReadingContainer{flex-grow: 40;}
div.ExerciseContainer{flex-grow: 60;}
</style>

Code for insertion into <head= tag

<style> Bl

div.ReadingContainerflex-grow: 40;}
div.ExerciseContainer{flex-grow: 60;}
=/style=

If empty, the widths will be 50% for ReadingContainer and 50% for ExerciseContainer.

V- Other tips

1- Mini audio button

With Hot Potatoes v7, via "Insert> Insert a media object", you can insert a classic HTMLS audio
player:

You can also use the HTML5 audio player button created for my Hot Potatoes add-ons: ,;,

| '}
o &

See audio_tutorial.pdf in the tutorials folder that you got when you unzipped JMM_201.zip.



2- Borders of checked cards
They are defined at the beginning of hp7.cs_.
Search for —strBorderWidth_IfChecked, near line 58:

/* added by AS */
--strBorderWidth IfDropped: 3px; /* for JMH */
--strBorderWidth IfUnDropped: lpx; /* for JMH,JMM */
--strBorderColor IfUnDropped: silver; /* for JMH, JMM */
--strBorderWidth IfChecked: 3px; /* for JMM */

You can modify the values in relation with JMM.

Don't forget to save the modified files.

3- Areas and map

The styles of the map and the areas are defined at the beginning of hp7.cs_ near line 61.

--strAreaBGColor: white; /*for JMM */
--strAreaBorderColor: silver; /* for JMM */
--strMapBorderWidth: 5px; /* for JMM */
--strMapBorderColor: silver; /* for JMM */
--strMapPadding: 50px; /* for JMM */

You can modify these values (you can find the names or the HTML hexadecimal codes for colours
on wikipedia ).
Don't forget to save the modified files.
4- Spaces
They are defined at the beginning of the djmatch?7.js_ file.

Search for this part near line 51:
[/ =

// variables : valeurs modifiables ; you can modify these variable values
[/ =

// entre les cartes d'une colonne

// between draggable cards

var spacerV = 5;

// entre les colonnes de cartes mobiles
// between lines of draggable cards
var spacerH RIC RIC = 10 ;

// entre image et carte mobile
// between image and draggable cards
var spacer IMG RIC = 30;

// entre div des boutons et image

// between checkbuttondiv and the image

var spacerV_topButtonDiv IMG = 10;

// alpha pour la couleur quand on drag (permet une transparence)

// alpha for color when dragging (transparency)
var alphaDragging = '0.4"';

You can change the values (5, 25 etc.).

Don't forget to save the modified files.


https://en.wikipedia.org/wiki/Web_colors
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